shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
The NEXTerra April Fools @ AOAA!
by Tom
12/01/18 10:48 AM
Shout Box

Who's Online
0 registered (), 80 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#374564 - 28/11/07 12:22 AM Big Thanks to Theo!
Anonymous
Unregistered


So, my truck died for no reason - and after a call from out of the blue to Theo, he stopped by and helped me out. I really appreciated it and it was great to meet you.

Sadly, my truck is still fubared. I bought a new battery and after driving around for two hours, I parked and shut it off and everything died. Lights, little blinky security light, door locks, everything. Doesn't even click when I go to start it. While I was driving around trying to charge the new battery, every time I stepped on the brakes the lights would flicker. So, I'm guessing it is running off the alternator. Help! Anyone have any ideas?

Top
#374565 - 28/11/07 01:16 AM Re: Big Thanks to Theo!
Anonymous
Unregistered


No problem. Luckily we live on a small island and I was only a few blocks away.

These are the lights that indicate bad alternator.


What battery did you get? There was a batch of Optimas that went out that had problems so you may just need to take the battery back. Unless you have gone through any deep water I doubt your alternator is dead. Sounds to me like a bad battery.

Top
#374566 - 28/11/07 02:11 AM Re: Big Thanks to Theo!
Anonymous
Unregistered


After I put the new battery in, I didn't get those lights while driving around, but I had to get it jumped again to get it started after I installed the new battery. The new battery is from Kmart (only place open) and is a DieHard.

EDIT: I AM A RETARD.

When I put the new battery in, I removed the little plastic cap for the positive terminal. But, since it was dark out, I didn't notice or think of the cap on the negative terminal. Explains why it ran after a jump until I shut it off. I saw it this morning when I was checking the cable, removed it, and it fired right up.

I wish I could blame that on [drink] , but I can't. If there is a dumb-ass award, that baby is mine! laugh

Top
#374567 - 28/11/07 09:45 AM Re: Big Thanks to Theo!
Anonymous
Unregistered


sweet glad its working now.

Top


Moderator:  Xterrian 

shrockworks xterraparts
XOC Decal