shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
Time To Replace Exhaust
by all2surreal
06/11/17 01:57 PM
2000 Xterra accessories for sale
by csebes
22/10/17 05:12 PM
Shout Box

Who's Online
0 registered (), 109 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#674125 - 19/12/10 08:55 PM Heater does not work when car is not moving
aliengin Offline
Junior Member

Registered: 19/12/10
Posts: 5
OK, before anyone says anything I did my search and found a lot of posts on the web with the same problem. Answer seems to be the cooler!
Its a 08 Xterra Off Road
Here is my problem:
Heater blows cool air not like AC but more like fan air when the car is not moving. You can feel it even when stopping at red lights. Once the car starts moving heat turns on. Also when the car is moving I can smell the fume like almost the heat is coming from engine department without any filtration, this happens even if I select circulate cabin air button.
Cooler was at the minimum level in the small reservour.
This is what i did:
I filled the reservoir to max level, and topped the radiator. Put the car on a ramp lifting front end, open the valve and run the engine for 15 minutes about 2000 rpms. I also turn the heat all the way up. After the process topped the radiator and filled the reservoir again to max. Drove for 20 minutes and problem still existed.
Second solution took the car to dealer and told them the problem. They said they didn't have the mechanic on Saturday but they told me they checked the pressure level in the rediator and couldn't find any problems.
Car does not over heat but again I am in Chicago and its around 15s! I checked the cooler again today and seems like it lost some since Friday. Level was a litle under Minimum level.
Its obvious that its loosing from somewhere and heater is sucking air from engine compartment. One other thing is when i turn the engine off if the heat is on I can hear some water bubling right behind the dashboard.
I am going to take the car to another service this week. Does anyone know what this could be?
Thanks.


Edited by aliengin (19/12/10 08:55 PM)

Top
#674126 - 19/12/10 09:16 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
You have air in the cooling system. The "bubling" you hear in the dash is air pockets circulating through the heater core. I'm not sure about your X, however a lot of new vehicles have an air bleed screw on the cooling system (usually on the thermostat housing or somewhere high on the engine) that you take out/loosen while filling the cooling system to purge the air. The reason they need those is because the hose drops below the highest point of the coolling system or the radiator fill neck is not the highest point of the cooling system. Once you get the air out of the system your heat will work fine. It is possible that you are losing coolant, howver it sounds like from what you are describing is that when the enghine cools it is purging some of the air and the fluid you are "losing" is displacing that air. This may be a symptom of another problem with the cooling system and not the problem as well (such as a leak allowing air into the cooling system or a coolant loss). I'd suggest taking it to a shop and have them pressure test the cooling system to see if you have a leak in it.
_________________________
2011 S 4X4 Night Armor 6 speed

Top
#674127 - 19/12/10 09:25 PM Re: Heater does not work when car is not moving [Re: ASTE25]
aliengin Offline
Junior Member

Registered: 19/12/10
Posts: 5
Well they did pressure test and they said everything is fine on Saturday.I am not sure about the air valve, but I'll check that now, I tried to bleed air through the cap but looks like didn't work. I just can't figure out while it is also blowing "dirty" air when the the car is moving. it is not the exhaust of other cars, this happens in an open road, feels like dusty engine air is coming through.

Top
#674130 - 19/12/10 09:45 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
I forgot to mention that you need to have your heat on when trying to purge the air out of the cooling system, that way water is circulating through the heater core . Try doing what you did with the engine running and the heater on all the way.
_________________________
2011 S 4X4 Night Armor 6 speed

Top
#674131 - 19/12/10 09:48 PM Re: Heater does not work when car is not moving [Re: ASTE25]
aliengin Offline
Junior Member

Registered: 19/12/10
Posts: 5
I did that also with the cap open. I don't think 08 Xterra Off Road has a air bleed valve. i couldn't find it, if anyone know can someone please point me where?

Top
#674132 - 19/12/10 09:51 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
Let me do some looking online. I'm certain your problem is air in the system, I've seen it a bunch of times. You describe the symptoms to a "T".
_________________________
2011 S 4X4 Night Armor 6 speed

Top
#674133 - 19/12/10 10:03 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
No luck finding if it has a bleeder valve, or if so it's location. You can always just try doing what you have ebbn doing a few times, it should purge itself. You just don't want to overheat the engine and really cause yourself a headache.
_________________________
2011 S 4X4 Night Armor 6 speed

Top
#674134 - 19/12/10 10:20 PM Re: Heater does not work when car is not moving [Re: ASTE25]
aliengin Offline
Junior Member

Registered: 19/12/10
Posts: 5
Just came down from the garage. Looked around nothing on the manual describing as a air bleed valve. In the engine compartment there were two valve looking things but i don't know what they are for. Both on the pipes, one is at the higher point than the radiator cap.
The smell I get in the cabin seems like a dried antifreeze. I overflow it on Friday and it spilled on the engine, that might be drying up and smelling. Like I said dealer did a pressutre test and couldn't find anything and the floor is dry. Only thing I can think of, it may loose fluid when the car is running from the pipes maybe?

Top
#674135 - 19/12/10 10:25 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
Are you sure those valves you saw were not on the air conditioner lines? If so those are not what I am talking about.
I've got an 11 X and I'm pretty sure they are the same, I went out and took a short look and did not see a bleed valve. You could unhook a water line up high and bleed it that way, however I'm not sure of your mechanical abalities/what you are confortable doing. I guess if it's not overheating I'd just take it to a shop and let them purge the air from the system. If I was there, I could do it easily for you, but, I'm not and I can't do it via e-mail. lol.


Edited by ASTE25 (19/12/10 10:26 PM)
_________________________
2011 S 4X4 Night Armor 6 speed

Top
#674136 - 19/12/10 10:33 PM Re: Heater does not work when car is not moving [Re: ASTE25]
aliengin Offline
Junior Member

Registered: 19/12/10
Posts: 5
I am not touching! I will take it to the shop this week. Hope I will survive the 6 mile drive to work tomorrow.

Top
#674144 - 20/12/10 02:40 PM Re: Heater does not work when car is not moving [Re: aliengin]
Gonzo-2 Offline
Member
***

Registered: 23/06/09
Posts: 518
Loc: Lansing, Michigan
There's a bleeder valve for the cooling system and it's on the top of the manifold. The bubbling is most likely as desceribed - air in the system. Just get the engine good and hot and with the heater on, open the bleeter valve until all air is out (that is, you start getting coolant out of the bleeder valve). Make sure to watch your coolant level too so it doesn't run low at the same time.

HTH!

-G
_________________________
'03SE

BFG AT/KO
Custom fuse panels for electrical mods
Custom backup solution mod (lights/camera/monitor)
Custom switched power outlets (8+ total)
Lots-o-Lights (6 driving lights, 10 total)

Original registration - Sep, '03
Pre-crash post count - ~1100

Top
#674148 - 20/12/10 11:21 PM Re: Heater does not work when car is not moving [Re: aliengin]
ASTE25 Offline
Member

Registered: 18/12/10
Posts: 20
Loc: New Market, Alabama
Well, what was the verdict?
_________________________
2011 S 4X4 Night Armor 6 speed

Top



shrockworks xterraparts
XOC Decal