shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
The NEXTerra April Fools @ AOAA!
by Tom
12/04/18 11:46 AM
Shout Box

Who's Online
0 registered (), 65 Guests and 1 Spider online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#679745 - 12/02/13 07:14 PM 2005 Xterra - No power at the fuel pump
gorlosky Offline
Junior Member

Registered: 12/02/13
Posts: 9
Need help. I have a 2005 Xterra and it just would not start one morning.
1. Pulled the spark plug and it was dry with good spark.
2. Pulled off the fuel connector at the engine and no pressure.
3. Listened for the fuel pump to run, when key is truned to ON, but no sound.
4. Checked the 15 amp fuse and it is good.
5. Swapped the Fog relay with the ECM relay, but no luck.
7. Confirmed that the fuel gauge was reading accurately.
8. No Security light on the dash, so that is good.
9. Tried the other key, but no luck.
10. Dropped the tank and tested using the red and black wires and the pump runs just fine.
11. Tested continuity for the fuel pump wiring harness Black ground and it is good.
12. Tested the fuel pump wiring harness and no power to the Red wire, when key is turned on.

What am I missing ?
Is there anything that I can check on either leg of the 15 amp fuse ?
Does anyone have a wiring diagram showing from the battery to the pump and the components in between ?

Top
#679746 - 13/02/13 06:05 AM Re: 2005 Xterra - No power at the fuel pump [Re: gorlosky]
TJ Offline
Member
*****

Registered: 08/03/01
Posts: 7756
Loc: Lawrenceville, NJ, USA
There might be a relay to the pump that went bad.

There's a wiring diagram in the 2005 FSM


Edited by TJ (13/02/13 06:06 AM)
_________________________
- TJ

2001 Xterra '03 VG33, SE 5 spd, 305/70/16's, Revolvers, UBSkidderz, Doubled AAL's, 3"SL/2"BL, winch/bumpers, skids, sliders, OBA, Snorkel, pine stripes....

Friends don't let friends drive stock.

http://www.gifsoup.com/view/501230/tj-tackling-crawlers-ridge-o.gif

Top
#679747 - 13/02/13 07:18 AM Re: 2005 Xterra - No power at the fuel pump [Re: TJ]
gorlosky Offline
Junior Member

Registered: 12/02/13
Posts: 9
Can you point me to the 2005 FSM on this forum or anywhere ?
I have an electronic version, but not sure if it is a Full Service Manual.
Edition: February 2005
Revision: February 2006
Publication No. SM5E-1N50U2
NISSAN XTERRA MODEL N50 SERIES

with these sections:
K ELECTRICAL
SC Starting & Charging System
LT Lighting System
DI Driver Information System
WW Wiper, Washer & Horn
BCS Body Control System
LAN LAN System
AV Audio Visual & Telephone System
ACS Auto Cruise Control System
PG Power Supply, Ground & Circuit Elements

In what section would I find the entire electrical path from Battery to Fuel Pump ?


Edited by gorlosky (13/02/13 07:19 AM)

Top
#679750 - 13/02/13 07:32 AM Re: 2005 Xterra - No power at the fuel pump [Re: gorlosky]
gorlosky Offline
Junior Member

Registered: 12/02/13
Posts: 9
Additionally I guess I am looking for a Troubleshooting Guide or a Diagnostic Guide that has the Step by Step and the Meter readings like depicted in Section G1
HOW TO FOLLOW TEST GROUPS IN TROUBLE DIAGNOSES

Top
#680252 - 04/07/13 11:31 PM Re: 2005 Xterra - No power at the fuel pump [Re: gorlosky]
camron Offline
Member

Registered: 01/07/13
Posts: 10
I think most of the time your ignition and other electrical system will not start when you have a problem with your alarm system or door sensor.Because when door sensor are not properly work the ignition system and other components don't work.So just disable the alarm and than try that.
_________________________
Be Secure, Be Safe

Top


Moderator:  Adam, fastdrmr, Gonzo-2, Smith 

shrockworks xterraparts
XOC Decal