shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
The NEXTerra April Fools @ AOAA!
by Tom
12/04/18 11:46 AM
Shout Box

Who's Online
0 registered (), 57 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#680015 - 15/04/13 04:29 PM Suspected Fuel Pump Relay - need help
gorlosky Offline
Junior Member

Registered: 12/02/13
Posts: 9
I have a 2005 Xterra and it would not start yesterday. I checked the 15 amp Fuel Pump fuse and the fuse is good and I have checked voltage on the hot side and it is good. I can not hear the pump in the tank run when the key is in the On position.
So I jumpered from the fuse to the pin 13 (red wire) coming out of the IPDM and it starts and runs fine.
Is this define the Fuel Pump Relay as bad, or do I need to verify that pin 46 (violet wire) has a good ground to the ECM, and therefore the ECM or the wire could be at fault ?
I don't want to prick the wire to test continuity, but there is no way to get a probe along side the wire in the connector.
Thanks

Top
#680016 - 15/04/13 04:48 PM Re: Suspected Fuel Pump Relay - need help [Re: gorlosky]
gorlosky Offline
Junior Member

Registered: 12/02/13
Posts: 9
Well I tested the violet wire by putting a needle through it and I have 352 ohms, and when On, I have full voltage.
I guess that should be enough to engage the relay, so I'm thinking it is the Fuel Pump Relay.
Now where can I get another one the cheapest ?


Edited by gorlosky (15/04/13 04:49 PM)

Top


Moderator:  Adam, fastdrmr, Gonzo-2, Smith 

shrockworks xterraparts
XOC Decal