shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
The NEXTerra April Fools @ AOAA!
by Tom
12/04/18 11:46 AM
Shout Box

Who's Online
0 registered (), 95 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#680811 - 30/12/13 05:41 PM Issues After Oil pump replacement 2000
Rick_75002 Offline
Junior Member

Registered: 30/12/13
Posts: 1
Loc: Texas
My son bought a 2000 2WD from a friend of ours. The dealer wanted $2400 to replace the oil pump. We replaced the oil pump, Water pump and timing belt. It runs fine but the check engine light came on after 40 miles. It is kicking codes 0340 Cam Shaft position sensor and 0325 Knock sensor. We had the codes cleared but they came back. I see a lot of posts that say to ignore the Knock sensor but the Cam Shaft position sensor has me baffled. It inst missing or running rough at all so I was wondering if there was something we need to reset after we did the timing belt and the sensor is getting the wrong signal.
Thanks in advance laugh

Top
#682559 - 26/06/14 10:45 AM Re: Issues After Oil pump replacement 2000 [Re: Rick_75002]
johnsx Offline
Member

Registered: 14/12/11
Posts: 17
Right ignore the knock sensor on your engine. it does nothing for a non super charged X. Mine on my 2000 x has been faulty for 10 years. The cam shaft sensor, check this http://www.obd-codes.com/p0340 could also be related to crank shaft position sensor too.
_________________________
Original owner 2000 X

Top



shrockworks xterraparts
XOC Decal