shrockworks xterraparts
XOC Decal
Newest Members
Glim, ChossWrangler, Patman, ChargedX, Randy Howerton
10084 Registered Users
Recent Posts
Front Sway Bar, end link bushings shot. your thoughts????
by purpelnoon
01/06/17 09:16 PM
1st Gen parts FS
by Oceancitysurf77
01/06/17 09:08 AM
Shout Box

Who's Online
0 registered (), 126 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Topic Options
Rate This Topic
#683023 - 29/01/17 06:16 PM '04 Cranks, wont start. Hoping I missed something simple...
adrenalinemedic Offline
Junior Member

Registered: 15/09/09
Posts: 1
Loc: Roseville, CA
Background: 2004 SE with 222,224 miles on it. It runs just fine, and was doing so on a drive down to SF on Friday. No issues with starting, low power, bogging down on hills, nothing. Sat morning I go to start it and it cranks strong but wont start.

Had it towed home, and have been troubleshooting all day.


I've ruled out:

Battery: tests as fine.

Battery connections: Cleaned and re tightened.

Fuses: Checked ALL fuses to be sure. Replaced fuel pump fuse because I could.

Fuel pump: You can hear it priming when the ignition is turned but not started.

Fuel sending unit: Checked for corrosion and melting on and around contacts. No issues.

Fuel filter: Just replaced it an hour ago.

Distro: Not loose. It's on its third distro, and this one went in 6 months ago and I checked timing two months ago. Contacts are clean and the rotor looks fine.

Timing belt. It's on it's third one (every 100k). I cranked it with the distro cap off and the rotor consistently turned.

Starter: It cranks just fine and the starter is about 2 years old.

Security system: Triggered and disarmed the alarm. Unlocked the car manually with key in drivers door.


It's not throwing any codes. It's not hesitant or slow to crank. The only thing I don't have is a spark tester, but if one of the plugs or wires was bad, it would catch and just run like crap.

Any suggestions?


Edited by adrenalinemedic (29/01/17 06:22 PM)

Top
#683025 - 04/02/17 02:49 PM Re: '04 Cranks, wont start. Hoping I missed something simple... [Re: adrenalinemedic]
Glim Offline
Junior Member

Registered: 06/01/17
Posts: 5
Loc: Sc
Have you checked fuel pressure? Also see if you are getting fire could be a cam or crank sensor
_________________________
It's not stuck I just like it there

Top



shrockworks xterraparts
XOC Decal